[500S] Netwerkschijf CH3net mount failed

Hallo,

Sinds 1 maand ben ik in het bezit van een dreambox 500. Ik ben er heel blij mee . Het enige wat ik nu nog wil is de divx films van mijn netwerkschijf (conceptronic ch3net met NFS support) afspelen via mijn dreambox. Ik heb de schijf een vast IP-adres (192.168.1.66) gegeven, is bereikbaar via mijn computer maar als ik het probeer te mounten op de dreambox krijg ik de melding “NFS mount ‘192.168.1.66/public /hdd/’ FAILED!”. Op mijn schijf staat alles onder Public en op mijn computer is het wel gelukt om de netwerkverbinding via ip adres te maken.

Kan iemand mij ajb verder helpen???

Het gaat over een CHD3net en niet over een CH3net zoals ik eerder doorgaf.

“Public” versus “public”? Het is wel hoofdlettergevoelig.

Het moest public zijn maar ik krijg toch steeds dezelfde melding. Om eerlijk te zijn weet ik ook niet precies hoe ik de schijf voor de dreambox moet instellen. Ik heb de opties: status waarbij ik de hostname en groupname kan veranderen. Verder heb ik SMB server, FTP server en Media server (als ik op deze klik krijg ik xbox 360 media server)

Ik kan je vast stap-voor-stap hier verder helpen, maar ik kan dat eigenlijk alleen goed voor de PLi image (heb vooral zelf al die mounts in PLi geprogrammeerd).

Bedankt dAF2000. Moet ik de PLi image dan installeren op de DB. Ik maak wel gebruik van cardsharing maar heb nog geen backup gemaakt van de DB.

Origineel bericht van: Triple-xxx

Bedankt dAF2000. Moet ik de PLi image dan installeren op de DB. Ik maak wel gebruik van cardsharing maar heb nog geen backup gemaakt van de DB.

Nee, ik kan je niet garanderen dat 't in PLi werkt ook al heb ik flink wat bugs opgelost. Bovendien wil ik je sharing tussen je twee eigen Dreamboxen niet op 't spel zetten

Probeer eens vanuit telnet:
mount -tnfs 192.168.1.66/public /hdd

Welke foutmelding krijg je dan? Moet je verder nog rekening houden met user/password van je netwerkschijf?

ik krijg dan invalid argument. ook heb ik mount -t nfs 192.168.1.66/public /hdd geprobeerd. maar krijg telkens weer invalid argument. Als ik mount -t nfs 192.168.1.66/:public /hdd krijg ik na een paar seconden RPC:Unable to receive; errno = Connection refused

oh ja, ik heb geen user en password voor public

Origineel bericht van: Triple-xxx

ik krijg dan invalid argument. ook heb ik mount -t nfs 192.168.1.66/public /hdd geprobeerd. maar krijg telkens weer invalid argument. Als ik mount -t nfs 192.168.1.66/:public /hdd krijg ik na een paar seconden RPC:Unable to receive; errno = Connection refused

Ik was inderdaad de dubbele punt vergeten, dus 192.168.1.66:/public
Weet je zeker dat dat ding NFS ondersteunt? Op de website van de fabrikant zie ik 't niet staan.

Probeer eens “cifs”:
mount -t cifs 192.168.1.66/public /hdd

Hallo dAF2000,

Ik heb de link opgezocht:

http://conceptronic.nl/site/desktopdefau…T&subid=559

Daarop lees ik:

Netwerk file sharing support

Ingebouwde FTP Server

UpnP AV server voor XBOX 360

Als ik

mount -t cifs 192.168.1.66:/public /hdd

probeer krijg ik

mount: RPC: Unable to receive; errno = Connection refused

mount: nfsmount failed: Bad file descriptor

mount: Mounting 192.168.1.66:/public on /hdd failed: Invalid argument

Origineel bericht van: Triple-xxx

Hallo dAF2000,

Ik heb de link opgezocht:
http://conceptronic.nl/site/desktopdefau…T&subid=559

Daarop lees ik:
Netwerk file sharing support
Ingebouwde FTP Server
UpnP AV server voor XBOX 360

Als ik
mount -t cifs 192.168.1.66:/public /hdd
probeer krijg ik
mount: RPC: Unable to receive; errno = Connection refused
mount: nfsmount failed: Bad file descriptor
mount: Mounting 192.168.1.66:/public on /hdd failed: Invalid argument

Klinkt inderdaad als NFS (tenzij ze iets anders bedoelen).

Ik ben er vast niet zo bij met m’n hoofd, want ik geef je elke keer verkeerde mount’s
Het moet zijn:
mount -t cifs //192.168.1.66/public /hdd

dan krijg ik

mount: Mounting //192.168.1.66/public on /hdd failed: Invalid argument

Op de schijf is er wel mogelijkheid voor SMB server en FTP server.

Is er misschien ook de mogelijheid om naar de ftp server te mounten?

smb zou kunnen, dan wordt het: -t smbfs (maar geen idee of dat al geinstalleerd is). Mounten via ftp lukt niet.

ik krijg dan ook invalid argument

???

t lijkt wel alsof mn mount commando’s anders moeten?

Tja, dan weet ik 't ook niet meer eigenlijk. 't Kan zijn dat die netwerkschijf “raar” is of dat 't aan je image ligt.

oke dAF2000, enorm bedankt voor de moeite.

morgen neem ik contact met conceptronic op om te vragen

Ik ben een poos aan het proberen geweest totdat ik ergens las dat je wanneer je SMB probeert te mounten altijd de username en pasword mee moet geven. Nadat ik dat deed en een hoofdletter gebruikte voor Public (dus hoofd en kleine letters doen ertoe!) lukte het eindelijk. Bij mij ziet het commando er nu zo uit:

mount -t cifs -o user=xxxxx,password=xxxxxxxx,rw //192.168.1.xxx/Public /hdd

uiteraard moet je de x-en vervangen door de betreffende username en password. Eventueel kan je nog parameters opgeven voor de lees- en schrijfbuffers.

Zelf heb ik sinds gisteren een CHD3NET.

De foutmelding wat ik dan krijg op het commando: mount -t cifs -o user=xxxxx,password=xxxxxxxx,rw //192.168.1.xxx/Public /hdd

=

mount: Mounting //192.168.1.xxx/Public on /hdd failed: Not a directory

ik heb dezelfde harddisk.

Haal even de laatste firmware van dat ding op. Dat scheelt een hoop.

http://www.conceptronic.net/site/desktop…T&subid=555

Bij mij werkte het eerst ook niet maar na de nieuwe firmware ging het goed.

Chris